Der Cursor verschwindet und der Text 'friert' ein.

Dieses Thema im Forum "Hilfe und Support" wurde erstellt von Flatty, 4. Juli 2022.

  1. Flatty

    Flatty New Member

    Hallo,

    Ich habe folgendes Problem. Regelmäßig »blockiert« mein Text (oder er »friert« ein). Weiss nicht, wie ich dies anders beschreiben soll. Ich konnte die Aktion bisher nicht ausfindig machen, die für dieses Verhalten verantwortlich ist. Mindestens einmal, so alle 10 bis 20 Minuten, ist plötzlich mein Cursor aus dem Text verschwunden. Ich kann nicht mehr weiter tippen. Versuche ich den Cursor innerhalb des Textes mit einem Mausklick ›neu‹ zu setzen, passiert nichts. Lediglich ein Doppelklick auf den Text lässt den Cursor wieder erscheinen.

    Weiss jemand Rat?

    Viele Grüße
    Flatty
     
  2. glucose

    glucose Well-Known Member

    Das klingt nach zeitweiser Überlastung des Systems, sodass die Tastatur- und Mauseingaben nicht mehr ordnungsgemäß verarbeitet werden können. Ist das unter macOS oder Windows? Welche Version von Papyrus?

    Manchmal verursacht der Duden-Korrektor solche Überlastungen. Ich würde deshalb probeweise die Rechtschreibkontrolle ausschalten und sehen, ob das Problem verschwindet. Wenn ja, dann das Dokument zum Support schicken, damit die Ursache für die Überlastung gesucht werden kann.

    Eine weitere Ursache für Überlastungen könnten Antivirenprogramme sein. Läuft da eines?
     
    Berti gefällt das.
  3. Ulli

    Ulli Administrator Mitarbeiter

    Spannend ist, dabei den Taskmanager des Betriebssystems zu beobachten (ruft sich je nach Betriebssystem verschieden auf).

    Da findet man schnell mal den Übeltäter (meist, wie glucose schon schrieb, ein Antivirus).
     
  4. Flatty

    Flatty New Member

    Hi,

    das System ist nicht überlastet und als Antivirensoftware habe ich nur die Microsoft-Boardmittel.
    Ich habe euch mal ein Video aufgenommen, indem ihr das Verhalten sehen könnt.



    Nachtrag: Es passiert auf unterschiedlichen Rechnern. Die Windows-Version ist jeweils Windows 10.

    Viele Grüße
    Flatty
     
    Zuletzt bearbeitet: 4. Juli 2022
  5. Stolpervogel

    Stolpervogel Well-Known Member

    Hallo Flatty,

    vermutlich hast du zuvor per Druck auf "ESC" den Cursor weggeschaltet. ESC war auch mit einem Moduswechsel verbunden, meine ich ...(Grafikmodus? Gerade nicht sicher - ein Mitforianer möge hier gerne aufschlauen).
    Aber ab dann musst du eben wirklich per Doppelklick wieder in den Text, um weiterzuschreiben.
     
    Waldfried und glucose gefällt das.
  6. Flatty

    Flatty New Member

    Hi,

    ja, es sieht so aus, als würde ein ESC genau dieses Verhalten provozieren. Kann ich das umkonfigurieren (Eine Option wie: Ignoriere ESC im Standard-Editor )? Oder zumindest mit einer anderen Tastenkombination wieder in den Schreibmodus wechseln? Warum ist dieses Verhalten überhaupt sinnvoll? Klar, wenn ich aus dem 'Schreibfokus' raus möchte, ist das Ok. Aber raus aus dem Schreibmodus, wenn ich im normalen Editor bin, scheint mir eher wie ein 'Bug'. Oder gibt es 'heimliche' Editier-Kommandos so wie im VI/VIM ?:)

    Viele Grüße,
    Flatty
     
  7. Stolpervogel

    Stolpervogel Well-Known Member

    Ich glaube, ESC kann man nicht neu zuweisen oder ändern. Mein Grafikmodus hat zusätzlich noch ein anderes Kürzel, aber ESC bleibt dennoch dafür erhalten (wenn ich die Taste im Textmodus drücke). Das scheint auch gewollt:

    Zitat aus dem Handbuch - Kapitel 15 "Handhabung von Bildern und Grafikobjekten"
     
    Zuletzt bearbeitet: 4. Juli 2022
  8. glucose

    glucose Well-Known Member

    Der Grafikmodus ist unter Text > Grafikmodus versteckt. Dort gibt es auch Text > Textmodus samt Tastenkürzel. Ich befürchte aber, dass letzteres im aktiven Grafikmodus nicht funktioniert.

    Ich finde den Wechsel in den Grafikmodus per Esc sehr hilfreich. Beim Tippen habe ich ihn noch nie aus Versehen ausgelöst. Und das Kürzel Esc existiert schon seit der ersten Version von Papyrus auf dem Atari vor 30 Jahren … :sick:
     
    Waldfried gefällt das.
  9. Flatty

    Flatty New Member

    Leider löse ich es recht häufig über mein Muskelgedächnis aus, da ich viel mit dem Editor VI/VIM schreibe. Dort wechselt man von der Texteingabe (Insert-Mode) per ESC in den Normal-Mode, in dem man Steuerungsbefehle etc. eingeben kann. So passiert es, dass ich beim Schreiben, nach einem Gedanklichen Textstück die Taste ESC drücke. Denn die Undo-Funktion staffelt dann, im VI, automatisch diese einzelnen Eingaben und macht Undo/Redo sehr komfortabel.

    Schade das es nur eine Tastenkombination gibt um in den Grafik-Modus hin, aber nicht zurück zu wechseln... *sniff*
     
  10. Waldfried

    Waldfried Well-Known Member

    Na doch, alt-F1 funktioniert.
     
  11. Flatty

    Flatty New Member

    Leider funktioniert dies nicht wie gewünscht. Der einzige Unterschied, den ich feststellen kann ist, dass ich nur noch 'normal' mit der Maus in den Text klicken muss und nicht wie vorher mit einem Doppelklick.
     
  12. Waldfried

    Waldfried Well-Known Member

    Ah, verstehe, ja, der Cursor muss erst wieder neu gesetzt werden. Insofern geht der Doppelklick dann natürlich schneller.
     
  13. Waldfried

    Waldfried Well-Known Member

    Immerhin sind ja die sonstigen "normalen" Escape-Funktionen unbeschadet, wie Rausgehen aus Dialogfenstern und Aufklappmenüs.

    Manipulieren lässt sich der Esc-Befehl m.W. nur im Datenbankkontext, wo sich für ein offenens Eingabeformular einstellen lässt, ob es geschlossen werden oder ob statt dessen ein Feldinhalt gelöscht werden soll. – In der DB-Tabelle bewirkt Esc ein Reset der Suche.